Creating Oracle Grid Infrastructure Management Repository Failed with ORA-15221

When upgrading Oracle 18c GI to 19c GI, Creating Oracle Grid Infrastructure Management Repository Failed.

Check the log which clearly shows the process can not create the password file due to compatible.asm  too low.

INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: 100% complete
INFO: [Apr 12, 2020 6:00:01 PM] [FATAL] Error in Process: /u01/app/19.0.0/grid/bin/orapwd
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: [FATAL] Error in Process: /u01/app/19.0.0/grid/bin/orapwd
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line:
INFO: [Apr 12, 2020 6:00:01 PM] Enter password for SYS:
WARNING: [Apr 12, 2020 6:00:01 PM] Missing secret argument for -winServiceUserPassword
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line:
INFO: [Apr 12, 2020 6:00:01 PM] OPW-00010: Could not create the password file.
WARNING: [Apr 12, 2020 6:00:01 PM] Missing secret argument for -winServiceUserPassword
INFO: [Apr 12, 2020 6:00:01 PM] ORA-15056: additional error message
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: ORA-15056: additional error message
INFO: [Apr 12, 2020 6:00:01 PM] ORA-06512: at line 4
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: ORA-06512: at line 4
INFO: [Apr 12, 2020 6:00:01 PM] ORA-15221: ASM operation requires compatible.asm of 12.1.0.0.0 or higher
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: ORA-15221: ASM operation requires compatible.asm of 12.1.0.0.0 or higher
INFO: [Apr 12, 2020 6:00:01 PM] ORA-06512: at "SYS.X$DBMS_DISKGROUP", line 679
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: ORA-06512: at "SYS.X$DBMS_DISKGROUP", line 679
INFO: [Apr 12, 2020 6:00:01 PM] ORA-06512: at line 2
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line: ORA-06512: at line 2
INFO: [Apr 12, 2020 6:00:01 PM] Skipping line:
INFO: [Apr 12, 2020 6:00:02 PM] Skipping line: 14% complete
INFO: [Apr 12, 2020 6:00:03 PM] Skipping line: 10% complete
INFO: [Apr 12, 2020 6:00:03 PM] Skipping line: 0% complete
INFO: [Apr 12, 2020 6:00:03 PM] Look at the log file "/u01/app/grid/cfgtoollogs/dbca/_mgmtdb/_mgmtdb3.log" for further details.
INFO: [Apr 12, 2020 6:00:03 PM] Skipping line: Look at the log file "/u01/app/grid/cfgtoollogs/dbca/_mgmtdb/_mgmtdb3.log" for further details.
INFO: [Apr 12, 2020 6:00:03 PM] Tool MGMTDBCDB returned code : 255
INFO: [Apr 12, 2020 6:00:03 PM] Completed Plugin named: mgmtdb
INFO: [Apr 12, 2020 6:00:03 PM] Completed Plugin named: mgmtdb
INFO: [Apr 12, 2020 6:08:21 PM] ConfigClient.saveSession method called
INFO: [Apr 12, 2020 6:08:21 PM] Creating Oracle Grid Infrastructure Management Repository failed.
INFO: [Apr 12, 2020 6:08:21 PM] Creating Oracle Grid Infrastructure Management Repository failed.

Check disk groups compatibility settings.

NAME      COMPATIBILITY  V
--------- -------------- -
DATA      12.1.0.0.0     N
FRA       11.2.0.4.0     N
OCR_VOTE  11.2.0.4.0     Y

Modify compatible.asm property of disk groups equal or higher than 12.1.0.0.0.

SQL> alter diskgroup OCR_VOTE set attribute 'compatible.asm'='12.1.0.0.0';

Diskgroup altered.

SQL> alter diskgroup FRA set attribute 'compatible.asm'='12.1.0.0.0';

Diskgroup altered.

Retry and continue the upgrading process successfully.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.